packages/libs/postgresql/patches/200-ranlib.patch
Daniel Golle b0f8e994f3 postgresql: update source to 9.5.1 and refresh patches
Setting the additional include path for host-build of ecpg is no
longer required and started breaking the build (PostgeSQL BUG-14033),
remove it.
Also, pgsql-server no longer requires shadow-su since procd can take
care of starting it running under the appropriate user.
Moving the dependency to pgsql-cli makes sense as the 'su' command is
still needed to boot-strap a new data directory and also commonly used
for other administration tasks. However, in that way the CLI and
shadow-su can be removed during production once pgsql-server has been
setup.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
2016-03-21 23:04:28 +01:00

10 lines
257 B
Diff

--- a/src/port/Makefile
+++ b/src/port/Makefile
@@ -53,6 +53,7 @@ uninstall:
libpgport.a: $(OBJS)
rm -f $@
$(AR) $(AROPT) $@ $^
+ $(RANLIB) libpgport.a
# thread.o needs PTHREAD_CFLAGS (but thread_srv.o does not)
thread.o: CFLAGS+=$(PTHREAD_CFLAGS)