According to PEP394 (http://legacy.python.org/dev/peps/pep-0394/) the 'python' command should refer to 'python2'. In our case, this means we should reboot the old python package. We could rename the package name to python2, but that would just complicate things a bit with other packages, and since we're doing this reboot, such a complication would be unnecessary. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
36 lines
1.6 KiB
Diff
36 lines
1.6 KiB
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -573,32 +573,7 @@ class PyBuildExt(build_ext):
|
|
# readline
|
|
do_readline = self.compiler.find_library_file(lib_dirs, 'readline')
|
|
readline_termcap_library = ""
|
|
- curses_library = ""
|
|
- # Determine if readline is already linked against curses or tinfo.
|
|
- if do_readline and find_executable('ldd'):
|
|
- fp = os.popen("ldd %s" % do_readline)
|
|
- ldd_output = fp.readlines()
|
|
- ret = fp.close()
|
|
- if ret is None or ret >> 8 == 0:
|
|
- for ln in ldd_output:
|
|
- if 'curses' in ln:
|
|
- readline_termcap_library = re.sub(
|
|
- r'.*lib(n?cursesw?)\.so.*', r'\1', ln
|
|
- ).rstrip()
|
|
- break
|
|
- if 'tinfo' in ln: # termcap interface split out from ncurses
|
|
- readline_termcap_library = 'tinfo'
|
|
- break
|
|
- # Issue 7384: If readline is already linked against curses,
|
|
- # use the same library for the readline and curses modules.
|
|
- if 'curses' in readline_termcap_library:
|
|
- curses_library = readline_termcap_library
|
|
- elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
|
|
- curses_library = 'ncursesw'
|
|
- elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
|
|
- curses_library = 'ncurses'
|
|
- elif self.compiler.find_library_file(lib_dirs, 'curses'):
|
|
- curses_library = 'curses'
|
|
+ curses_library = "ncurses"
|
|
|
|
if platform == 'darwin':
|
|
os_release = int(os.uname()[2].split('.')[0])
|