According to PEP394 (http://legacy.python.org/dev/peps/pep-0394/) the 'python' command should refer to 'python2'. In our case, this means we should reboot the old python package. We could rename the package name to python2, but that would just complicate things a bit with other packages, and since we're doing this reboot, such a complication would be unnecessary. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
43 lines
1.7 KiB
Diff
43 lines
1.7 KiB
Diff
---
|
|
setup.py | 30 ------------------------------
|
|
1 file changed, 30 deletions(-)
|
|
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -307,36 +307,6 @@ class PyBuildExt(build_ext):
|
|
ext_filename = os.path.join(
|
|
self.build_lib,
|
|
self.get_ext_filename(self.get_ext_fullname(ext.name)))
|
|
- try:
|
|
- imp.load_dynamic(ext.name, ext_filename)
|
|
- except ImportError, why:
|
|
- self.failed.append(ext.name)
|
|
- self.announce('*** WARNING: renaming "%s" since importing it'
|
|
- ' failed: %s' % (ext.name, why), level=3)
|
|
- assert not self.inplace
|
|
- basename, tail = os.path.splitext(ext_filename)
|
|
- newname = basename + "_failed" + tail
|
|
- if os.path.exists(newname):
|
|
- os.remove(newname)
|
|
- os.rename(ext_filename, newname)
|
|
-
|
|
- # XXX -- This relies on a Vile HACK in
|
|
- # distutils.command.build_ext.build_extension(). The
|
|
- # _built_objects attribute is stored there strictly for
|
|
- # use here.
|
|
- # If there is a failure, _built_objects may not be there,
|
|
- # so catch the AttributeError and move on.
|
|
- try:
|
|
- for filename in self._built_objects:
|
|
- os.remove(filename)
|
|
- except AttributeError:
|
|
- self.announce('unable to remove files (ignored)')
|
|
- except:
|
|
- exc_type, why, tb = sys.exc_info()
|
|
- self.announce('*** WARNING: importing extension "%s" '
|
|
- 'failed with %s: %s' % (ext.name, exc_type, why),
|
|
- level=3)
|
|
- self.failed.append(ext.name)
|
|
|
|
def get_platform(self):
|
|
# Get value of sys.platform
|