According to PEP394 (http://legacy.python.org/dev/peps/pep-0394/) the 'python' command should refer to 'python2'. In our case, this means we should reboot the old python package. We could rename the package name to python2, but that would just complicate things a bit with other packages, and since we're doing this reboot, such a complication would be unnecessary. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
50 lines
2.1 KiB
Diff
50 lines
2.1 KiB
Diff
---
|
|
setup.py | 15 ++-------------
|
|
1 file changed, 2 insertions(+), 13 deletions(-)
|
|
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -368,11 +368,6 @@ class PyBuildExt(build_ext):
|
|
os.unlink(tmpfile)
|
|
|
|
def detect_modules(self):
|
|
- # Ensure that /usr/local is always used
|
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
- self.add_multiarch_paths()
|
|
-
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
# CPPFLAGS for header and library files.
|
|
# We must get the values from the Makefile and not the environment
|
|
@@ -407,17 +402,6 @@ class PyBuildExt(build_ext):
|
|
for directory in reversed(options.dirs):
|
|
add_dir_to_list(dir_list, directory)
|
|
|
|
- if os.path.normpath(sys.prefix) != '/usr' \
|
|
- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
|
|
- # OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
|
|
- # (PYTHONFRAMEWORK is set) to avoid # linking problems when
|
|
- # building a framework with different architectures than
|
|
- # the one that is currently installed (issue #7473)
|
|
- add_dir_to_list(self.compiler.library_dirs,
|
|
- sysconfig.get_config_var("LIBDIR"))
|
|
- add_dir_to_list(self.compiler.include_dirs,
|
|
- sysconfig.get_config_var("INCLUDEDIR"))
|
|
-
|
|
try:
|
|
have_unicode = unicode
|
|
except NameError:
|
|
@@ -426,11 +410,8 @@ class PyBuildExt(build_ext):
|
|
# lib_dirs and inc_dirs are used to search for files;
|
|
# if a file is found in one of those directories, it can
|
|
# be assumed that no additional -I,-L directives are needed.
|
|
- lib_dirs = self.compiler.library_dirs + [
|
|
- '/lib64', '/usr/lib64',
|
|
- '/lib', '/usr/lib',
|
|
- ]
|
|
- inc_dirs = self.compiler.include_dirs + ['/usr/include']
|
|
+ lib_dirs = self.compiler.library_dirs
|
|
+ inc_dirs = self.compiler.include_dirs
|
|
exts = []
|
|
missing = []
|
|
|