packages/libs/libcap/patches/300-uclibc-ng.patch
Rosen Penev 3a559224b3
libcap: Fix compilation with uClibc-ng
The test does not compile with --static.

As this does not touch binaries, not bumping the package release.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-01-10 18:37:18 -08:00

11 lines
403 B
Diff

--- a/tests/Makefile
+++ b/tests/Makefile
@@ -32,7 +32,7 @@ run_libcap_psx_test: libcap_psx_test
./libcap_psx_test
libcap_psx_test: libcap_psx_test.c $(DEPS)
- $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create --static
+ $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create
clean:
rm -f psx_test psx_test_wrap libcap_psx_test