New feature release for ruby.More info: https://www.ruby-lang.org/en/news/2015/12/25/ruby-2-3-0-released/ Patches changes: (-) 001-rdoc-remove_gems_dep.patch was merged (+) 001-acinclude.m4_rename_aclocal.m4.patch backported from upstream. Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
152 lines
5.3 KiB
Diff
152 lines
5.3 KiB
Diff
https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/53414
|
||
|
||
Fixes:
|
||
|
||
https://bugs.ruby-lang.org/issues/11941
|
||
|
||
It might be incorporated in the following release
|
||
|
||
Index: aclocal.m4
|
||
===================================================================
|
||
--- a/aclocal.m4 (revision 53413)
|
||
+++ b/aclocal.m4 (revision 53414)
|
||
@@ -1,46 +0,0 @@
|
||
-# -*- autoconf -*-
|
||
-
|
||
-AC_DEFUN([_COLORIZE_RESULT_PREPARE], [
|
||
- msg_checking= msg_result_yes= msg_result_no= msg_result_other= msg_reset=
|
||
- AS_IF([test "x${CONFIGURE_TTY}" = xyes -o -t 1], [
|
||
- msg_begin="`tput smso 2>/dev/null`"
|
||
- AS_CASE(["$msg_begin"], ['@<:@'*m],
|
||
- [msg_begin="`echo "$msg_begin" | sed ['s/[0-9]*m$//']`"
|
||
- msg_checking="${msg_begin}33m"
|
||
- AS_IF([test ${TEST_COLORS:+set}], [
|
||
- msg_result_yes=[`expr ":$TEST_COLORS:" : ".*:pass=\([^:]*\):"`]
|
||
- msg_result_no=[`expr ":$TEST_COLORS:" : ".*:fail=\([^:]*\):"`]
|
||
- msg_result_other=[`expr ":$TEST_COLORS:" : ".*:skip=\([^:]*\):"`]
|
||
- ])
|
||
- msg_result_yes="${msg_begin}${msg_result_yes:-32;1}m"
|
||
- msg_result_no="${msg_begin}${msg_result_no:-31;1}m"
|
||
- msg_result_other="${msg_begin}${msg_result_other:-33;1}m"
|
||
- msg_reset="${msg_begin}m"
|
||
- ])
|
||
- AS_UNSET(msg_begin)
|
||
- ])
|
||
- AS_REQUIRE_SHELL_FN([colorize_result],
|
||
- [AS_FUNCTION_DESCRIBE([colorize_result], [MSG], [Colorize result])],
|
||
- [AS_CASE(["$[]1"],
|
||
- [yes], [AS_ECHO(["${msg_result_yes}$[]1${msg_reset}]")],
|
||
- [no], [AS_ECHO(["${msg_result_no}$[]1${msg_reset}]")],
|
||
- [AS_ECHO(["${msg_result_other}$[]1${msg_reset}]")])])
|
||
-])
|
||
-
|
||
-AC_DEFUN([COLORIZE_RESULT], [AC_REQUIRE([_COLORIZE_RESULT_PREPARE])dnl
|
||
- AS_LITERAL_IF([$1],
|
||
- [m4_case([$1],
|
||
- [yes], [AS_ECHO(["${msg_result_yes}$1${msg_reset}"])],
|
||
- [no], [AS_ECHO(["${msg_result_no}$1${msg_reset}"])],
|
||
- [AS_ECHO(["${msg_result_other}$1${msg_reset}"])])],
|
||
- [colorize_result "$1"]) dnl
|
||
-])
|
||
-
|
||
-AC_DEFUN([AC_CHECKING],[dnl
|
||
-AC_REQUIRE([_COLORIZE_RESULT_PREPARE])dnl
|
||
-AS_MESSAGE([checking ${msg_checking}$1${msg_reset}...])])
|
||
-
|
||
-AC_DEFUN([AC_MSG_RESULT], [dnl
|
||
-{ _AS_ECHO_LOG([result: $1])
|
||
-COLORIZE_RESULT([$1]); dnl
|
||
-}])
|
||
Index: acinclude.m4
|
||
===================================================================
|
||
--- a/acinclude.m4 (revision 0)
|
||
+++ b/acinclude.m4 (revision 53414)
|
||
@@ -0,0 +1,46 @@
|
||
+# -*- autoconf -*-
|
||
+
|
||
+AC_DEFUN([_COLORIZE_RESULT_PREPARE], [
|
||
+ msg_checking= msg_result_yes= msg_result_no= msg_result_other= msg_reset=
|
||
+ AS_IF([test "x${CONFIGURE_TTY}" = xyes -o -t 1], [
|
||
+ msg_begin="`tput smso 2>/dev/null`"
|
||
+ AS_CASE(["$msg_begin"], ['@<:@'*m],
|
||
+ [msg_begin="`echo "$msg_begin" | sed ['s/[0-9]*m$//']`"
|
||
+ msg_checking="${msg_begin}33m"
|
||
+ AS_IF([test ${TEST_COLORS:+set}], [
|
||
+ msg_result_yes=[`expr ":$TEST_COLORS:" : ".*:pass=\([^:]*\):"`]
|
||
+ msg_result_no=[`expr ":$TEST_COLORS:" : ".*:fail=\([^:]*\):"`]
|
||
+ msg_result_other=[`expr ":$TEST_COLORS:" : ".*:skip=\([^:]*\):"`]
|
||
+ ])
|
||
+ msg_result_yes="${msg_begin}${msg_result_yes:-32;1}m"
|
||
+ msg_result_no="${msg_begin}${msg_result_no:-31;1}m"
|
||
+ msg_result_other="${msg_begin}${msg_result_other:-33;1}m"
|
||
+ msg_reset="${msg_begin}m"
|
||
+ ])
|
||
+ AS_UNSET(msg_begin)
|
||
+ ])
|
||
+ AS_REQUIRE_SHELL_FN([colorize_result],
|
||
+ [AS_FUNCTION_DESCRIBE([colorize_result], [MSG], [Colorize result])],
|
||
+ [AS_CASE(["$[]1"],
|
||
+ [yes], [AS_ECHO(["${msg_result_yes}$[]1${msg_reset}]")],
|
||
+ [no], [AS_ECHO(["${msg_result_no}$[]1${msg_reset}]")],
|
||
+ [AS_ECHO(["${msg_result_other}$[]1${msg_reset}]")])])
|
||
+])
|
||
+
|
||
+AC_DEFUN([COLORIZE_RESULT], [AC_REQUIRE([_COLORIZE_RESULT_PREPARE])dnl
|
||
+ AS_LITERAL_IF([$1],
|
||
+ [m4_case([$1],
|
||
+ [yes], [AS_ECHO(["${msg_result_yes}$1${msg_reset}"])],
|
||
+ [no], [AS_ECHO(["${msg_result_no}$1${msg_reset}"])],
|
||
+ [AS_ECHO(["${msg_result_other}$1${msg_reset}"])])],
|
||
+ [colorize_result "$1"]) dnl
|
||
+])
|
||
+
|
||
+AC_DEFUN([AC_CHECKING],[dnl
|
||
+AC_REQUIRE([_COLORIZE_RESULT_PREPARE])dnl
|
||
+AS_MESSAGE([checking ${msg_checking}$1${msg_reset}...])])
|
||
+
|
||
+AC_DEFUN([AC_MSG_RESULT], [dnl
|
||
+{ _AS_ECHO_LOG([result: $1])
|
||
+COLORIZE_RESULT([$1]); dnl
|
||
+}])
|
||
|
||
Property changes on: acinclude.m4
|
||
___________________________________________________________________
|
||
Added: svn:eol-style
|
||
## -0,0 +1 ##
|
||
+LF
|
||
\ No newline at end of property
|
||
Index: common.mk
|
||
===================================================================
|
||
--- a/common.mk (revision 53413)
|
||
+++ b/common.mk (revision 53414)
|
||
@@ -518,7 +518,7 @@
|
||
$(Q)$(RM) id.c id.h probes.dmyh
|
||
$(Q)$(CHDIR) $(srcdir) && $(exec) $(RM) parse.c parse.h lex.c enc/trans/newline.c $(PRELUDES) revision.h
|
||
$(Q)$(CHDIR) $(srcdir) && $(exec) $(RM) id.c id.h probes.dmyh
|
||
- $(Q)$(CHDIR) $(srcdir) && $(exec) $(RM) configure tool/config.guess tool/config.sub gems/*.gem
|
||
+ $(Q)$(CHDIR) $(srcdir) && $(exec) $(RM) configure aclocal.m4 tool/config.guess tool/config.sub gems/*.gem
|
||
realclean-ext:: PHONY
|
||
realclean-golf: distclean-golf
|
||
$(Q)$(RM) $(GOLFPRELUDES)
|
||
Index: Makefile.in
|
||
===================================================================
|
||
--- a/Makefile.in (revision 53413)
|
||
+++ b/Makefile.in (revision 53414)
|
||
@@ -22,6 +22,7 @@
|
||
YACC = bison
|
||
PURIFY =
|
||
AUTOCONF = autoconf
|
||
+ACLOCAL = aclocal
|
||
CONFIGURE = @CONFIGURE@
|
||
@SET_MAKE@
|
||
MKFILES = @MAKEFILES@
|
||
@@ -310,6 +311,9 @@
|
||
$(srcdir)/$(CONFIGURE): $(srcdir)/configure.in $(srcdir)/aclocal.m4
|
||
$(CHDIR) $(srcdir) && exec $(AUTOCONF) -o $(@F)
|
||
|
||
+$(srcdir)/aclocal.m4: $(srcdir)/acinclude.m4
|
||
+ $(CHDIR) $(srcdir) && exec $(ACLOCAL)
|
||
+
|
||
incs: id.h
|
||
all-incs: probes.h
|
||
|