Based on debian patch. LDFLAGS were not being passed, which caused relro to not be applies. Also made stock CFLAGS optional. -fkeep-inline was keeping sizes high. Removed PKG_NO_MIPS16 as the original problem seems to be gone. Size from 54338 to 50761 Signed-off-by: Rosen Penev <rosenp@gmail.com>
13 lines
710 B
Diff
13 lines
710 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -13,9 +13,8 @@ oldmandir = $(manprefix)/man
|
|
CC ?= gcc
|
|
STRIP ?= strip
|
|
|
|
-CFLAGS := -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
|
|
+CFLAGS ?= -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
|
|
|
|
-LDFLAGS = -s
|
|
#LDFLAGS = -s -static
|
|
INSTALL = install
|
|
INSTALL_DATA = $(INSTALL) -m 644
|