packages/utils/fuse/patches/112-no_break_on_mknod.patch
Rosen Penev 348358bd50
fuse: import from base
This belongs here. All dependent packages are located here.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-05-16 17:26:30 -07:00

11 lines
415 B
Diff

--- a/util/Makefile.in
+++ b/util/Makefile.in
@@ -723,7 +723,7 @@ mount_util.c: $(top_srcdir)/lib/mount_ut
install-exec-hook:
-chmod u+s $(DESTDIR)$(bindir)/fusermount
- @if test ! -e $(DESTDIR)/dev/fuse; then \
+ -@if test ! -e $(DESTDIR)/dev/fuse; then \
$(MKDIR_P) $(DESTDIR)/dev; \
echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229 || true"; \
mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229 || true; \