At the moment, only build these softmmu emulators for x86_64 and sunxi target. The decision was made for the following reasons - It seems that interests of virtualization with qemu are mostly from x86, and ARM recently. - x86, sunxi boards/boxes capable of running qemu with accel=kvm are more widely available - Not all host, target combinations of qemu works, or even compiles - Extra maintenance work and server resources Test results are as the following - Nested vmx works: lede-qemu-x86_64-kvm on lede-qemu-x86_64-kvm - KVM on Cubieboard2 works - tcg with malta works: lede-qemu-malta-tcg on lede-qemu-malta-tcg. But it's too slow to be useful thus not included in this version - mips64 host does not compile Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
10 lines
409 B
Diff
10 lines
409 B
Diff
--- a/pixman/configure.ac.orig 2016-11-22 20:44:21.205150763 +0800
|
|
+++ b/pixman/configure.ac 2016-11-22 20:44:55.505161500 +0800
|
|
@@ -720,7 +720,6 @@ dnl Check if assembler is gas compatible
|
|
have_mips_dspr2=no
|
|
AC_MSG_CHECKING(whether to use MIPS DSPr2 assembler)
|
|
xserver_save_CFLAGS=$CFLAGS
|
|
-CFLAGS="-mdspr2 $CFLAGS"
|
|
|
|
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
|
|
#if !(defined(__mips__) && __mips_isa_rev >= 2)
|