packages/utils/moreutils/patches/001_disable-manuals.patch
Rosen Penev 70ddd72b98 moreutils: Update to 0.62 and switch to git tarball
It's more generic in addition to being the source for the debian package.

PKG_BUILD_PARALLEL was explicitly set to no just in case as I see no
handling for it in the Makefile.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2018-09-02 19:23:38 -07:00

21 lines
515 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@ endif
DOCBOOK2XMAN=xsltproc --param man.authors.section.enabled 0 $(DOCBOOKXSL)/manpages/docbook.xsl
-all: $(BINS) $(MANS)
+all: $(BINS)
clean:
rm -f $(BINS) $(MANS) dump.c errnos.h errno.o \
@@ -28,9 +28,6 @@ install:
$(INSTALL_BIN) $(BINS) $(DESTDIR)$(PREFIX)/bin
install $(PERLSCRIPTS) $(DESTDIR)$(PREFIX)/bin
- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
- install $(MANS) $(DESTDIR)$(PREFIX)/share/man/man1
-
check: isutf8
./is_utf8/test.sh