packages/utils/procps-ng/patches/100-no-tests-docs.patch
Jo-Philipp Wich 3048ebedec procps-ng: fix build on systems without gettext development utilities
The current procps-ng Makefile calls the shipped autogen.sh script which
introduces incorrect implicit dependencies on host utilities, leading to
the following error observed on a minimal build system:

    (cd .../procps-ng-3.3.11; echo "3.3.11" > ".../procps-ng-3.3.11/.tarball-version"; ./autogen.sh );
    You must have autopoint installed to generate procps-ng build system.
    The autopoint command is part of the GNU gettext package.
    Makefile:96: recipe for target '.../procps-ng-3.3.11/.configured_yynyyyyy' failed
    make[3]: *** [.../procps-ng-3.3.11/.configured_yynyyyyy] Error 1

Apply the following changes in order to fix compilation:

 - Apply the generic autoreconf fixup to generate configure and Makefiles
 - Use Build/Prepare to populate .tarball-version and revert Build/Configure
   to its default implementation
 - Disable to build of docs and tests as those require additional utilities
   not guaranteed to be present

Fixes #2890.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
2016-06-24 10:16:46 +02:00

26 lines
602 B
Diff

--- a/Makefile.am
+++ b/Makefile.am
@@ -13,10 +13,7 @@ PACKAGE_VERSION = @PACKAGE_VERSION@
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = \
- include \
- man-po \
- po \
- testsuite
+ include
AM_CFLAGS = -Iproc
LDADD = ./proc/libprocps.la $(CYGWINFLAGS)
--- a/configure.ac
+++ b/configure.ac
@@ -256,8 +256,5 @@ AC_CHECK_FUNCS([__fpending alarm atexit
AC_CONFIG_FILES([Makefile
include/Makefile
- man-po/Makefile
- po/Makefile.in
- proc/libprocps.pc
- testsuite/Makefile])
+ proc/libprocps.pc])
AC_OUTPUT