packages/libs/libudev-zero/patches/0011-Revert-Makefile-add-stub-symbol-versioning.patch
Florian Eckert 0c66639a28 libudev-zero: backport latest changes to fix blocking on devices scan
This change added the latest upstream changes since version 1.0.0.

When using the smart plugin from collectd, there are problems with the
function udev_enumerate_scan_devices. This function is blocked and no
longer returns. Backporting the latest fixes from libudev-zero solves
the problem.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
2022-03-16 19:46:41 -07:00

28 lines
910 B
Diff

From b8a0b953e6305dffeea57886fa379c5aca1b8397 Mon Sep 17 00:00:00 2001
From: illiliti <illiliti@protonmail.com>
Date: Tue, 16 Nov 2021 16:17:40 +0300
Subject: [PATCH 11/15] Revert "Makefile: add stub symbol versioning"
This reverts commit 000ff7bf2fa463ea99afaea8503c2ed9f8a1852c.
---
Makefile | 3 +--
libudev.sym | 1 -
2 files changed, 1 insertion(+), 3 deletions(-)
delete mode 100644 libudev.sym
--- a/Makefile
+++ b/Makefile
@@ -8,8 +8,7 @@ PKGCONFIGDIR = ${LIBDIR}/pkgconfig
XCFLAGS = ${CPPFLAGS} ${CFLAGS} -std=c99 -fPIC -pthread -D_XOPEN_SOURCE=700 \
-Wall -Wextra -Wpedantic -Wmissing-prototypes -Wstrict-prototypes \
-Wno-unused-parameter
-XLDFLAGS = ${LDFLAGS} -shared -Wl,-soname,libudev.so.1 \
- -Wl,-version-script,libudev.sym
+XLDFLAGS = ${LDFLAGS} -shared -Wl,-soname,libudev.so.1
XARFLAGS = -rc
OBJ = \
--- a/libudev.sym
+++ /dev/null
@@ -1 +0,0 @@
-LIBUDEV_183 {};