Drops an openssl deprecation patch applied upstream. Changes since 3.0.0, the following list of websocket related features: * gzip+brotli compression in the webserver * threadpools * string tokenizers * http reverse proxies * managed disk cache Full changes at https://libwebsockets.org/git/libwebsockets/tree/changelog?id=89eedcaa94e1c8a97ea3af10642fd224bcea068f#n4 Tested on ath79, and classic usage of libwebsockets to provide websockets support to a C application. Signed-off-by: Karl Palsson <karlp@etactica.com>
14 lines
855 B
Diff
14 lines
855 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1233,9 +1233,9 @@ if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COM
|
|
endif()
|
|
|
|
if (UNIX AND NOT LWS_WITH_ESP32)
|
|
- set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized -Werror ${VISIBILITY_FLAG} -Wundef ${GCOV_FLAGS} ${CMAKE_C_FLAGS} ${ASAN_FLAGS}" )
|
|
+ set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized ${VISIBILITY_FLAG} -Wundef ${GCOV_FLAGS} ${CMAKE_C_FLAGS} ${ASAN_FLAGS}" )
|
|
else()
|
|
- set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized -Werror ${VISIBILITY_FLAG} ${GCOV_FLAGS} ${CMAKE_C_FLAGS}" )
|
|
+ set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized ${VISIBILITY_FLAG} ${GCOV_FLAGS} ${CMAKE_C_FLAGS}" )
|
|
endif()
|
|
endif ()
|
|
|