packages/lang/python/python-crypto/patches/002-fix-endianness-detect.patch
Jeffery To fa60629c99 python-crypto: add python3 variant, src packages, omit tests
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2018-01-14 22:31:01 +08:00

13 lines
419 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -100,6 +100,10 @@ def PrintErr(*args, **kwd):
w(kwd.get("end", "\n"))
def endianness_macro():
+ if os.environ["CONFIG_BIG_ENDIAN"] == "y":
+ return ('PCT_BIG_ENDIAN', 1)
+ else:
+ return ('PCT_LITTLE_ENDIAN', 1)
s = struct.pack("@I", 0x33221100)
if s == "\x00\x11\x22\x33".encode(): # little endian
return ('PCT_LITTLE_ENDIAN', 1)