packages/net/unbound/patches/010-configure-uname.patch
Josef Schlehofer 2abe98e134
unbound: update to version 1.15.0
Refresh patch

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
2022-02-11 17:11:44 +01:00

14 lines
438 B
Diff

OpenWrt (modification):
Fix cross compile errors by inserting an environment variable for the
target. Use "uname" on host only if "UNAME" variable is empty.
--- a/configure.ac
+++ b/configure.ac
@@ -811,7 +811,7 @@ if test x_$ub_test_python != x_no; then
fi
fi
-if test "`uname`" = "NetBSD"; then
+if test "${UNAME:-`uname`}" = "NetBSD"; then
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
AC_SUBST(NETBSD_LINTFLAGS)
fi