Re-worked patch `003-do-not-run-distutils-tests.patch` to reduce patch-size. Removed `011-fix-ncursesw-definition-colisions.patch` it is fixed upstream. Refreshed with `make package/python3/refresh` Resetting PKG_RELEASE to 1. This variable was never used for pip3 & setuptools, since VERSION is specified in the package definitions. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
18 lines
923 B
Diff
18 lines
923 B
Diff
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1341,6 +1341,7 @@ libinstall: build_all $(srcdir)/Modules/
|
|
$(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
|
|
$(DESTDIR)$(LIBDEST); \
|
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
|
+ifeq (@COMPILE_ALL_TESTS@,yes)
|
|
if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
|
|
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
|
|
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
|
|
@@ -1376,6 +1377,7 @@ libinstall: build_all $(srcdir)/Modules/
|
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
|
|
+endif
|
|
|
|
python-config: $(srcdir)/Misc/python-config.in Misc/python-config.sh
|
|
# Substitution happens here, as the completely-expanded BINDIR
|