packages/libs/libfolly/patches/100-cmake-fix-regex-match-path.patch
Rosen Penev 2973b57a39
libfolly: Update to 2019.09.02
Several optimizations to reduce size. ~35KB. Mostly because of LTO.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-09-09 11:34:14 -07:00

40 lines
1.5 KiB
Diff

Index: folly-2019.05.06.00/CMakeLists.txt
===================================================================
--- folly-2019.05.06.00.orig/CMakeLists.txt
+++ folly-2019.05.06.00/CMakeLists.txt
@@ -109,17 +109,19 @@ configure_file(
auto_sources(files "*.cpp" "RECURSE" "${FOLLY_DIR}")
auto_sources(hfiles "*.h" "RECURSE" "${FOLLY_DIR}")
+string(REPLACE + \\+ FOLLY_DIR_ESCAPED ${FOLLY_DIR})
+
# Exclude tests, benchmarks, and other standalone utility executables from the
# library sources. Test sources are listed separately below.
REMOVE_MATCHES_FROM_LISTS(files hfiles
MATCHES
- "^${FOLLY_DIR}/build/"
- "^${FOLLY_DIR}/experimental/exception_tracer/"
- "^${FOLLY_DIR}/experimental/pushmi/"
- "^${FOLLY_DIR}/futures/exercises/"
- "^${FOLLY_DIR}/logging/example/"
- "^${FOLLY_DIR}/(.*/)?test/"
- "^${FOLLY_DIR}/tools/"
+ "^${FOLLY_DIR_ESCAPED}/build/"
+ "^${FOLLY_DIR_ESCAPED}/experimental/exception_tracer/"
+ "^${FOLLY_DIR_ESCAPED}/experimental/pushmi/"
+ "^${FOLLY_DIR_ESCAPED}/futures/exercises/"
+ "^${FOLLY_DIR_ESCAPED}/logging/example/"
+ "^${FOLLY_DIR_ESCAPED}/(.*/)?test/"
+ "^${FOLLY_DIR_ESCAPED}/tools/"
"Benchmark.cpp$"
"Test.cpp$"
)
@@ -172,7 +174,7 @@ list(APPEND hfiles
if (NOT FOLLY_USE_SYMBOLIZER)
REMOVE_MATCHES_FROM_LISTS(files hfiles
MATCHES
- "^${FOLLY_DIR}/experimental/symbolizer/"
+ "^${FOLLY_DIR_ESCAPED}/experimental/symbolizer/"
)
list(REMOVE_ITEM files
${FOLLY_DIR}/SingletonStackTrace.cpp