packages/net/mdns-repeater/Makefile
Paul Fertser 0c10c224be treewide: remove AUTORELEASE
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used.

The following temporary change was made to the core:

diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
 abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))

 COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))

 all:
 FORCE: ;

And this command used to fix affected packages:

for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
                              sed 's^.*/\([^/]*\)/Makefile^\1^';);
do
  make package/$i/download
done

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
2023-04-21 22:46:58 +02:00

47 lines
1.3 KiB
Makefile

#
# This is free software, licensed under the GNU General Public License v2.
# See LICENSE.txt for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=mdns-repeater
PKG_RELEASE:=1
PKG_SOURCE_URL:=https://github.com/kennylevinsen/mdns-repeater.git
PKG_SOURCE_PROTO=git
PKG_SOURCE_DATE:=2020-05-03
PKG_SOURCE_VERSION:=921d8850e988d0bd8d60899d933c4ad3094d73ca
PKG_MIRROR_HASH:=11c1988d42ec36945516697be93a6f7f7155535a432af61bcf61ef4a19fec439
PKG_MAINTAINER:=Alexander Koenig <alex@lisas.de>
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=LICENSE.txt
include $(INCLUDE_DIR)/package.mk
define Package/mdns-repeater
SECTION:=net
CATEGORY:=Network
TITLE:=Multicast DNS repeater for Linux
URL:=https://github.com/kennylevinsen/mdns-repeater
endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
define Build/Compile
CFLAGS="$(TARGET_CFLAGS)" CPPFLAGS="$(TARGET_CPPFLAGS)" $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS)
endef
define Package/mdns-repeater/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mdns-repeater $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/mdns-repeater.init $(1)/etc/init.d/mdns-repeater
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/mdns_repeater.conf $(1)/etc/config/mdns_repeater
endef
$(eval $(call BuildPackage,mdns-repeater))