packages/libs/postgresql/patches/700-no-arm-crc-march-change.patch
Daniel Golle ead096d6dd
postgresql: update to version 14.5
Release date: 2022-08-11
Adresses CVE-2022-2625.
For more details, please see the release notes[1].

[1]: https://www.postgresql.org/docs/release/14.5/
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
2022-09-07 22:56:35 +01:00

15 lines
563 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -2141,9 +2141,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
# flags. If not, check if adding -march=armv8-a+crc flag helps.
# CFLAGS_ARMV8_CRC32C is set if the extra flag is required.
PGAC_ARMV8_CRC32C_INTRINSICS([])
-if test x"$pgac_armv8_crc32c_intrinsics" != x"yes"; then
- PGAC_ARMV8_CRC32C_INTRINSICS([-march=armv8-a+crc])
-fi
+#if test x"$pgac_armv8_crc32c_intrinsics" != x"yes"; then
+# PGAC_ARMV8_CRC32C_INTRINSICS([-march=armv8-a+crc])
+#fi
AC_SUBST(CFLAGS_ARMV8_CRC32C)
# Select CRC-32C implementation.