Refreshed patches. And apply hack for line-endings in pep517 (from pip). Hack comment: # FIXME: [1] get rid of this asap; 'patch' doesn't like Windows endings, and this file is full of them... # I actually tried this in a number of ways and the only way to fix this is to implement # a poor-man's dos2unix using sed. # The issue is with the pip package; it seems that it throws in some Windows line-endings # and 'patch' won't handle them. So, we do a "dos2unix" and then patch. # We can get rid of this once this is solved upstream and in pip: # https://github.com/pypa/pep517/pull/130 Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
13 lines
758 B
Diff
13 lines
758 B
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -714,8 +714,9 @@ class PyBuildExt(build_ext):
|
|
# directly since an inconsistently reproducible issue comes up where
|
|
# the environment variable is not set even though the value were passed
|
|
# into configure and stored in the Makefile (issue found on OS X 10.3).
|
|
+ rt_lib_dirs = [] if CROSS_COMPILING else self.compiler.runtime_library_dirs
|
|
for env_var, arg_name, dir_list in (
|
|
- ('LDFLAGS', '-R', self.compiler.runtime_library_dirs),
|
|
+ ('LDFLAGS', '-R', rt_lib_dirs),
|
|
('LDFLAGS', '-L', self.compiler.library_dirs),
|
|
('CPPFLAGS', '-I', self.compiler.include_dirs)):
|
|
env_val = sysconfig.get_config_var(env_var)
|