Refreshed patches. And apply hack for line-endings in pep517 (from pip). Hack comment: # FIXME: [1] get rid of this asap; 'patch' doesn't like Windows endings, and this file is full of them... # I actually tried this in a number of ways and the only way to fix this is to implement # a poor-man's dos2unix using sed. # The issue is with the pip package; it seems that it throws in some Windows line-endings # and 'patch' won't handle them. So, we do a "dos2unix" and then patch. # We can get rid of this once this is solved upstream and in pip: # https://github.com/pypa/pep517/pull/130 Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
12 lines
389 B
Diff
12 lines
389 B
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -737,7 +737,8 @@ class PyBuildExt(build_ext):
|
|
# only change this for cross builds for 3.3, issues on Mageia
|
|
if CROSS_COMPILING:
|
|
self.add_cross_compiling_paths()
|
|
- self.add_multiarch_paths()
|
|
+ else:
|
|
+ self.add_multiarch_paths()
|
|
self.add_ldflags_cppflags()
|
|
|
|
def init_inc_lib_dirs(self):
|