packages/net/udpxy/Makefile
Paul Fertser 0c10c224be treewide: remove AUTORELEASE
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used.

The following temporary change was made to the core:

diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
 abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))

 COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))

 all:
 FORCE: ;

And this command used to fix affected packages:

for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
                              sed 's^.*/\([^/]*\)/Makefile^\1^';);
do
  make package/$i/download
done

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
2023-04-21 22:46:58 +02:00

63 lines
1.8 KiB
Makefile

#
# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=udpxy
PKG_VERSION:=1.0-25.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/pcherenkov/udpxy/tar.gz/$(PKG_VERSION)?
PKG_HASH:=a1a16e60895c6b2fd151321db47f5d5373843116f1b98ed9749e6c25a6c44497
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=chipmunk/gpl.txt
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
MAKE_PATH:=chipmunk
define Package/udpxy
SECTION:=net
CATEGORY:=Network
TITLE:=Convert UDP IPTV streams into HTTP streams
URL:=https://github.com/pcherenkov/udpxy
endef
define Package/udpxy/description
udproxy makes it possible to convert UDP IPTV streams into HTTP
streams which can be viewed even over WLANs. HTTP streams do
not generate huge amounts of multicast traffic, so a sd stream
only takes about 300k. Interesting for peoply who have IPTV at
home and do not want to rent multiple decoders from their
provider but just use their own streaming client (for example
popcornhour/mediatomb/vlc).
endef
define Package/udpxy/conffiles
/etc/config/udpxy
endef
MAKE_FLAGS += \
INSTALLROOT="$(PKG_INSTALL_DIR)/usr" \
ALL_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)"
define Package/udpxy/install
$(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/config
$(INSTALL_CONF) ./files/udpxy.conf $(1)/etc/config/udpxy
$(INSTALL_BIN) ./files/udpxy.init $(1)/etc/init.d/udpxy
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/udpxy $(1)/usr/bin/
ln -sf udpxy $(1)/usr/bin/udpxrec
endef
$(eval $(call BuildPackage,udpxy))