packages/lang/php5/patches/950-Fix-dl-cross-compiling-issue.patch
W. Michael Petullo 7771752217 Copy php5 from old repository and update
Signed-off-by: W. Michael Petullo <mike@flyn.org>
2014-09-28 21:56:33 -04:00

14 lines
370 B
Diff

--- a/configure.in
+++ b/configure.in
@@ -453,7 +453,10 @@ PHP_CHECK_FUNC(gethostname, nsl)
PHP_CHECK_FUNC(gethostbyaddr, nsl)
PHP_CHECK_FUNC(yp_get_default_domain, nsl)
-PHP_CHECK_FUNC(dlopen, dl)
+PHP_ADD_LIBRARY(dl)
+PHP_DEF_HAVE(dlopen)
+PHP_DEF_HAVE(libdl)
+ac_cv_func_dlopen=yes
if test "$ac_cv_func_dlopen" = "yes"; then
AC_DEFINE(HAVE_LIBDL, 1, [ ])
fi