Faster compilation. Removed autotools patches. Backported meson patch to fix compilation and pkgconfig file. Before: time make package/spice/compile -j 12 Executed in 62.85 secs fish external usr time 56.45 secs 276.00 micros 56.45 secs sys time 8.06 secs 46.00 micros 8.06 secs Before + PKG_BUILD_PARALLEL: Executed in 45.40 secs fish external usr time 63.08 secs 253.00 micros 63.08 secs sys time 8.57 secs 44.00 micros 8.57 secs After: time make package/spice/compile -j 12 Executed in 16.54 secs fish external usr time 41.29 secs 266.00 micros 41.29 secs sys time 4.76 secs 45.00 micros 4.76 secs Signed-off-by: Rosen Penev <rosenp@gmail.com>
19 lines
520 B
Diff
19 lines
520 B
Diff
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -192,8 +192,6 @@ add_project_arguments(compiler.get_supported_arguments(spice_server_global_cflag
|
|
# Subdirectories
|
|
#
|
|
subdir('server')
|
|
-subdir('tools')
|
|
-subdir('docs')
|
|
|
|
#
|
|
# write config.h
|
|
--- a/server/meson.build
|
|
+++ b/server/meson.build
|
|
@@ -186,5 +186,3 @@ spice_server_libs = both_libraries('spice-server', spice_server_sources,
|
|
|
|
spice_server_shared_lib = spice_server_libs.get_shared_lib()
|
|
spice_server_static_lib = spice_server_libs.get_static_lib()
|
|
-
|
|
-subdir('tests')
|