packages/libs/spice/patches/010-librt-libm.patch
Rosen Penev dcc79a8d2f
spice: convert to meson
Faster compilation.

Removed autotools patches.

Backported meson patch to fix compilation and pkgconfig file.

Before:

time make package/spice/compile -j 12
Executed in   62.85 secs   fish           external
   usr time   56.45 secs  276.00 micros   56.45 secs
   sys time    8.06 secs   46.00 micros    8.06 secs

Before + PKG_BUILD_PARALLEL:

Executed in   45.40 secs   fish           external
   usr time   63.08 secs  253.00 micros   63.08 secs
   sys time    8.57 secs   44.00 micros    8.57 secs

After:

time make package/spice/compile -j 12
Executed in   16.54 secs   fish           external
   usr time   41.29 secs  266.00 micros   41.29 secs
   sys time    4.76 secs   45.00 micros    4.76 secs

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-10-10 00:00:05 -07:00

28 lines
873 B
Diff

From 26bbb85c150f882c05399e4c574208b8b1242082 Mon Sep 17 00:00:00 2001
From: James Le Cuirot <chewi@gentoo.org>
Date: Tue, 7 Apr 2020 19:32:15 +0100
Subject: [PATCH] build: Fix librt and libm dependencies in Meson
They need to be requested without the lib prefix, otherwise a
generated pkg-config file ends up with absolute paths instead of -l
flags.
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Acked-by: Frediano Ziglio <fziglio@redhat.com>
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 1685c077..f9090a82 100644
--- a/meson.build
+++ b/meson.build
@@ -102,7 +102,7 @@ foreach dep : ['libjpeg', 'zlib']
endforeach
if host_machine.system() != 'windows'
- foreach dep : ['librt', 'libm']
+ foreach dep : ['rt', 'm']
spice_server_deps += compiler.find_library(dep)
endforeach
else