Maintainer: @EricLuehrsen Compile tested: x86/64 Run tested: x86/64 Description: Update to 1.16.2, fix CVE-2022-30698 and CVE-2022-30699. Signed-off-by: Pascal Ernster <git@hardfalcon.net>
14 lines
438 B
Diff
14 lines
438 B
Diff
OpenWrt (modification):
|
|
Fix cross compile errors by inserting an environment variable for the
|
|
target. Use "uname" on host only if "UNAME" variable is empty.
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -814,7 +814,7 @@ if test x_$ub_test_python != x_no; then
|
|
fi
|
|
fi
|
|
|
|
-if test "`uname`" = "NetBSD"; then
|
|
+if test "${UNAME:-`uname`}" = "NetBSD"; then
|
|
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
|
|
AC_SUBST(NETBSD_LINTFLAGS)
|
|
fi
|