This patch upgrades the collectd package from 5.7.2 to 5.8.2. All openwrt patches got either updated or deleted in case they are already included into upstream collectd. The new collectd 5.8.0 package compiles and got tested on current lede trunk with latest luci on an PCengines APU. All default plugins (enabled via Openwrt Makefile) - so also iwinfo - are running fine with the new version. Signed-off-by: Thomas Huehn <thomas@net.t-labs.tu-berlin.de> Amended with the following changes: * preserve git file history by avoiding unnecessary patch renames * mark new plugins introduced with 5.8 branch as disabled Compile tested all plugins with ipq806x Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
43 lines
1.2 KiB
Diff
43 lines
1.2 KiB
Diff
Patch reverts upstream commit:
|
|
https://github.com/collectd/collectd/commit/6124da7a48f28f54fc09ebeb942d1037516fe6ab
|
|
|
|
The commit changed the detection path due to FreeBSD issues,
|
|
but apparently affects also Openwrt buildroot negatively.
|
|
|
|
Original explanation:
|
|
From 6124da7a48f28f54fc09ebeb942d1037516fe6ab Mon Sep 17 00:00:00 2001
|
|
Subject: [PATCH] Fix libmodbus detection on FreeBSD
|
|
|
|
We look for modbus/modbus.h in /usr/local/include/modbus
|
|
but we should look for modbus.h
|
|
|
|
This is only an issue on FreeBSD since /usr/local/include is not
|
|
in the default search path.
|
|
|
|
Reversed patch to be applied:
|
|
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3327,9 +3327,9 @@ if test "x$with_libmodbus" = "xyes"; the
|
|
SAVE_CPPFLAGS="$CPPFLAGS"
|
|
CPPFLAGS="$CPPFLAGS $with_libmodbus_cflags"
|
|
|
|
- AC_CHECK_HEADERS([modbus.h],
|
|
+ AC_CHECK_HEADERS([modbus/modbus.h],
|
|
[with_libmodbus="yes"],
|
|
- [with_libmodbus="no (modbus.h not found)"]
|
|
+ [with_libmodbus="no (modbus/modbus.h not found)"]
|
|
)
|
|
|
|
CPPFLAGS="$SAVE_CPPFLAGS"
|
|
--- a/src/modbus.c
|
|
+++ b/src/modbus.c
|
|
@@ -26,7 +26,7 @@
|
|
#include "configfile.h"
|
|
#include "plugin.h"
|
|
|
|
-#include <modbus.h>
|
|
+#include <modbus/modbus.h>
|
|
#include <netdb.h>
|
|
#include <sys/socket.h>
|
|
|