packages/libs/libgpg-error/patches/001-cross-compile-fix.patch
Rosen Penev b468d5cf57 libgpg-error: Update to 1.34
Remove FPIC as it is already default. Both fPIC and DPIC are passed.

Some extra configure arguments to speed up build times.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-01-23 16:01:29 -08:00

21 lines
479 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,18 @@ AM_SILENT_RULES
AC_CANONICAL_HOST
AB_INIT
+case "${host}" in
+ x86_64-openwrt-linux-gnu|i?86-openwrt-linux-gnu)
+ host=$(echo $host | sed 's/openwrt/pc/g')
+ ;;
+ arm-openwrt-linux-gnu|armeb-openwrt-linux-gnu)
+ host=arm-unknown-linux-gnueabi
+ ;;
+ *)
+ host=$(echo $host | sed 's/openwrt/unknown/g')
+ ;;
+esac
+
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O