packages/utils/collectd/patches/003-remove-werror.patch
Hannu Nyman 106fd6a3a2 collectd: update to 5.5.0
Update collectd, base of Luci statistics, to 5.5.0.

Patches have been refreshed.
write-graphite plugin is now enabled. (see #1351)

I have compile-tested all plugins with ar71xx,
and real-life tested the following plugins:
Conntrack, Processor (CPU), DNS, Interfaces, Wireless, System Load,
Memory, Ping, Uptime

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
2015-07-16 15:15:22 +03:00

22 lines
600 B
Diff

--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,7 +7,7 @@ SUBDIRS += daemon
PLUGIN_LDFLAGS = -module -avoid-version -export-symbols-regex '\<module_register\>'
if COMPILER_IS_GCC
-AM_CFLAGS = -Wall -Werror
+AM_CFLAGS = -Wall
endif
AM_CPPFLAGS = -I$(srcdir)/daemon
--- a/src/libcollectdclient/Makefile.am
+++ b/src/libcollectdclient/Makefile.am
@@ -1,7 +1,7 @@
AUTOMAKE_OPTIONS = foreign no-dependencies
if COMPILER_IS_GCC
-AM_CFLAGS = -Wall -Werror
+AM_CFLAGS = -Wall
endif
pkginclude_HEADERS = collectd/client.h collectd/network.h collectd/network_buffer.h collectd/lcc_features.h