packages/net/pdns/patches/100-pdns-disable-pdns.conf-dist.patch
Rosen Penev 1a3582ac63 pdns: update to 4.4.0
Use new AUTORELEASE variable.

Enable reproducible builds.

Remove Upstreamed patches. Refresh other one.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-02-07 16:56:20 -08:00

39 lines
905 B
Diff

diff --git a/pdns/Makefile.am b/pdns/Makefile.am
index 2df5fa7..2246088 100644
--- a/pdns/Makefile.am
+++ b/pdns/Makefile.am
@@ -71,7 +71,6 @@ CLEANFILES = \
backends/gsql/gsqlbackend.gcno \
backends/gsql/gsqlbackend.gcov \
dnsmessage.pb.cc dnsmessage.pb.h \
- pdns.conf-dist \
apidocfiles.h \
api-swagger.yaml \
api-swagger.json
@@ -99,7 +98,6 @@ apidocfiles.h: api-swagger.yaml api-swagger.json
./incfiles $^ > $@
noinst_SCRIPTS = pdns.init
-sysconf_DATA = pdns.conf-dist
sbin_PROGRAMS = pdns_server
bin_PROGRAMS = \
@@ -139,7 +137,7 @@ if IXFRDIST
bin_PROGRAMS += \
ixfrdist
-sysconf_DATA += \
+sysconf_DATA = \
ixfrdist.example.yml
endif
@@ -1278,9 +1276,6 @@ dnspcap2protobuf_LDADD = \
endif
endif
-pdns.conf-dist: pdns_server
- $(AM_V_GEN)./pdns_server --config=default 2>/dev/null > $@
-
testrunner_SOURCES = \
arguments.cc \
auth-caches.cc auth-caches.hh \