packages/utils/open-vm-tools/patches/0007-include-poll.h-instead-of-sys-poll.h.patch
Rosen Penev e495e1985e
open-vm-tools: update to 11.1.15
Refreshed patches. Reworked several of them as musl has changed.
Removed several upstreamed ones.

Added musl 1.2.0 patch which uses 64-bit time_t.

Removed -Werror as there's a redefinition warning caused by nls.mk.

Replaced glib2/host dependency with rpcsvc-proto.

Fixed compilation with full NLS.

Fixed compilation with musl 1.2.0

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-10-09 03:51:42 -07:00

12 lines
270 B
Diff

--- a/lib/asyncsocket/asyncsocket.c
+++ b/lib/asyncsocket/asyncsocket.c
@@ -69,8 +69,8 @@
#else
#include <stddef.h>
#include <ctype.h>
+#include <poll.h>
#include <sys/types.h>
-#include <sys/poll.h>
#include <sys/socket.h>
#include <sys/un.h>
#include <netdb.h>