Refreshed patches. Reworked several of them as musl has changed. Removed several upstreamed ones. Added musl 1.2.0 patch which uses 64-bit time_t. Removed -Werror as there's a redefinition warning caused by nls.mk. Replaced glib2/host dependency with rpcsvc-proto. Fixed compilation with full NLS. Fixed compilation with musl 1.2.0 Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
246 B
Diff
11 lines
246 B
Diff
--- a/services/plugins/vix/vixTools.c
|
|
+++ b/services/plugins/vix/vixTools.c
|
|
@@ -66,7 +66,7 @@
|
|
#include <unistd.h>
|
|
#endif
|
|
|
|
-#if defined(sun) || defined(__FreeBSD__) || defined(__APPLE__)
|
|
+#ifdef HAVE_SYS_STAT_H
|
|
#include <sys/stat.h>
|
|
#endif
|
|
|