packages/lang/php7/patches/1003-Fix-dl-cross-compiling-issue.patch
Michael Heimpold 80cdd53134 php7: update to 7.2.16
Also refresh patch which does not apply cleanly anymore.

Run tested on Duckbill for mxs platform.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
2019-03-13 22:21:16 +01:00

27 lines
894 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -422,7 +422,10 @@ PHP_CHECK_FUNC(gethostname, nsl)
PHP_CHECK_FUNC(gethostbyaddr, nsl)
PHP_CHECK_FUNC(yp_get_default_domain, nsl)
-PHP_CHECK_FUNC(dlopen, dl)
+PHP_ADD_LIBRARY(dl)
+PHP_DEF_HAVE(dlopen)
+PHP_DEF_HAVE(libdl)
+ac_cv_func_dlopen=yes
if test "$ac_cv_func_dlopen" = "yes"; then
AC_DEFINE(HAVE_LIBDL, 1, [ ])
fi
--- a/ext/fileinfo/config.m4
+++ b/ext/fileinfo/config.m4
@@ -46,6 +46,10 @@ int main(void)
AC_MSG_RESULT(no)
AC_MSG_NOTICE(using libmagic strcasestr implementation)
libmagic_sources="$libmagic_sources libmagic/strcasestr.c"
+ ],[
+ dnl cross-compiling; assume not present
+ AC_MSG_NOTICE(using libmagic strcasestr implementation)
+ libmagic_sources="$libmagic_sources libmagic/strcasestr.c"
])
PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)