packages/libs/libupm/patches/001-version.patch
Rosen Penev e8845b49a2 libupm: Update to 1.7.1
The libmraa update introduced several API changes that broke libupm.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2018-11-30 13:01:44 -08:00

18 lines
667 B
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -225,14 +225,7 @@ include(GNUInstallDirs)
set (LIB_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}" CACHE PATH "Installation path for libraries")
# Make a version file containing the current version from git.
-include (GetGitRevisionDescription)
-git_describe (VERSION "--tags")
-# If git_describe fails, use a dirty version
-if (${VERSION} MATCHES -NOTFOUND)
- set (VERSION "v1.7.1")
- message (WARNING "Failed to retrieve UPM version with 'git describe' (using "
- "${VERSION}). Check that git is installed and this is a valid git repo.")
-endif ()
+set (VERSION "v1.7.1")
message (STATUS "UPM Version ${VERSION}")