packages/lang/python/python3/patches/015-abort-on-failed-modules.patch
Martin Strobel fe01c8fc05 python3: update to python 3.7.0
Fixes python3 host SSL build -> host-pip can use https:// urls again.
Updates Pip to 10.0.1
rebased patches

Signed-off-by: Martin Strobel <arctus@crza.de>
2018-07-11 06:34:54 +02:00

10 lines
322 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -354,6 +354,7 @@ class PyBuildExt(build_ext):
print("Failed to build these modules:")
print_three_column(failed)
print()
+ if cross_compiling: sys.exit(1)
if self.failed_on_import:
failed = self.failed_on_import[:]