packages/libs/glib2/patches/005-uclibc.patch
Rosen Penev e1d8f4fc96 glib2: update to 2.68.1
Removed two now pointless patches as they were added as options.

Switch to AUTORELEASE for simplicity.

Update MESON_ARGS.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-04-13 15:30:10 -07:00

13 lines
569 B
Diff

--- a/meson.build
+++ b/meson.build
@@ -2038,8 +2038,8 @@ endif
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
libintl_deps = []
-if cc.has_function('ngettext')
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
+if true
+ have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset', prefix :'#include <libintl.h>')
else
# First just find the bare library.
libintl = cc.find_library('intl', required : false)