Both dependent packages (sumo and libelektra) use (and must use) libstdcpp Two libc++ cannot be linked against each other at the same time. I believe this causes xerces-c to not be used even though it is listed as a dependency. Took the time to clean up the Makefile. Also replaced -fPIC with -fpic to eliminate potential issues. Added linker flags for smaller size. Signed-off-by: Rosen Penev <rosenp@gmail.com>
20 lines
658 B
Diff
20 lines
658 B
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -228,7 +228,7 @@ AC_COMPILE_IFELSE( [AC_LANG_PROGRAM([[#
|
|
]
|
|
)
|
|
AC_MSG_CHECKING([for wcsrtombs])
|
|
-AC_RUN_IFELSE( [AC_LANG_PROGRAM([[#include <wchar.h>
|
|
+AC_COMPILE_IFELSE( [AC_LANG_PROGRAM([[#include <wchar.h>
|
|
#include <string.h>]],
|
|
[[
|
|
mbstate_t st;
|
|
@@ -250,7 +250,7 @@ else
|
|
]
|
|
)
|
|
AC_MSG_CHECKING([for mbsrtowcs])
|
|
-AC_RUN_IFELSE( [AC_LANG_PROGRAM([[#include <wchar.h>
|
|
+AC_COMPILE_IFELSE( [AC_LANG_PROGRAM([[#include <wchar.h>
|
|
#include <string.h>]],
|
|
[[
|
|
mbstate_t st;
|