POrtable COmponents is a Modern, powerful open source C++ class libraries for building network- and internet-based applications that run on desktop, server, mobile and embedded systems. Original Makefile --> https://dev.openwrt.org/browser/packages/libs/poco/Makefile add license add maintainer update URL to latest github stable version (1.7.0) change patch to the configure file add a patch to build with musl-libc Signed-off-by: Jean-Michel Julien <jean-michel.julien@trilliantinc.com>
11 lines
428 B
Diff
11 lines
428 B
Diff
--- a/Foundation/src/Error.cpp
|
|
+++ b/Foundation/src/Error.cpp
|
|
@@ -66,7 +66,7 @@
|
|
without -D_GNU_SOURCE is needed, otherwise the GNU version is
|
|
preferred.
|
|
*/
|
|
-#if defined _GNU_SOURCE && !POCO_ANDROID
|
|
+#if (defined _GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__)) && !POCO_ANDROID
|
|
char errmsg[256] = "";
|
|
return std::string(strerror_r(errorCode, errmsg, 256));
|
|
#elif (_XOPEN_SOURCE >= 600) || POCO_ANDROID
|