packages/utils/podman/patches/010-do-not-build-docs.patch
Oskari Rauta 4eac9e8a2f podman: update to v4.4.2
Security:
 - This release fixes CVE-2023-0778, which allowed a malicious user to potentially replace a normal file in a volume with a symlink while exporting the volume, allowing for access to arbitrary files on the host file system.

Bugfixes:
 - Fixed a bug where containers started via the podman-kube systemd template would always use the "passthrough" log driver (#17482).
 - Fixed a bug where pulls would unexpectedly encounter an EOF error. Now, Podman automatically transparently resumes aborted pull connections.
 - Fixed a race condition in Podman's signal proxy.

Misc:
 - Updated the containers/image library to v5.24.1.

Patch also refreshed

Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
2023-02-27 09:29:45 -08:00

20 lines
591 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -206,7 +206,7 @@ GV_SHA=aab0ac9367fc5142f5857c36ac2352bcb
default: all
.PHONY: all
-all: binaries docs
+all: binaries
.PHONY: binaries
ifeq ($(shell uname -s),FreeBSD)
@@ -797,7 +797,7 @@ package-install: package ## Install rpm
/usr/bin/podman info # will catch a broken conmon
.PHONY: install
-install: install.bin install.remote install.man install.systemd ## Install binaries to system locations
+install: install.bin install.remote install.systemd ## Install binaries to system locations
.PHONY: install.catatonit
install.catatonit: