packages/utils/mariadb/patches/210-no-altivec.patch
Michal Hrusecky 6328e3e9fe mariadb: Update to the latest version 10.9.3
Update to the latest upstream version. For more details, see:

https://mariadb.com/kb/en/changes-improvements-in-mariadb-109/

Added new dependency on libfmt.

Following two patches dropped as the issues were fixed in upstream.

 * 130-c11_atomics.patch
 * 140-mips-connect-unaligned.patch

The rest of the patches were refreshed.

Don't need to disable cassandra and tokudb anymore as they were dropped
from upstream tarball.

Signed-off-by: Michal Hrusecky <michal@hrusecky.net>
2022-10-25 18:02:11 -07:00

21 lines
821 B
Diff

--- a/mysys/CMakeLists.txt
+++ b/mysys/CMakeLists.txt
@@ -141,7 +141,7 @@ ELSEIF(CMAKE_SYSTEM_PROCESSOR MATCHES "a
ENDIF()
ENDIF()
-IF(CMAKE_SYSTEM_PROCESSOR MATCHES "ppc64|powerpc64" OR CMAKE_SYSTEM_NAME MATCHES AIX)
+IF(FALSE)
SET(MYSYS_SOURCES ${MYSYS_SOURCES} crc32/crc32_ppc64.c crc32/crc32c_ppc.c)
SET_SOURCE_FILES_PROPERTIES(crc32/crc32_ppc64.c crc32/crc32c_ppc.c PROPERTIES
COMPILE_FLAGS "${COMPILE_FLAGS} -maltivec -mvsx -mpower8-vector -mcrypto -mpower8-vector")
--- a/mysys/crc32ieee.cc
+++ b/mysys/crc32ieee.cc
@@ -52,7 +52,6 @@ static my_crc32_t init_crc32()
static const my_crc32_t my_checksum_func= init_crc32();
#ifdef __powerpc64__
-# error "my_checksum() is defined in mysys/crc32/crc32_ppc64.c"
#endif
extern "C"
uint32 my_checksum(uint32 crc, const void *data, size_t len)