Update to the latest upstream version. For more details, see: https://mariadb.com/kb/en/changes-improvements-in-mariadb-109/ Added new dependency on libfmt. Following two patches dropped as the issues were fixed in upstream. * 130-c11_atomics.patch * 140-mips-connect-unaligned.patch The rest of the patches were refreshed. Don't need to disable cassandra and tokudb anymore as they were dropped from upstream tarball. Signed-off-by: Michal Hrusecky <michal@hrusecky.net>
11 lines
525 B
Diff
11 lines
525 B
Diff
--- a/support-files/CMakeLists.txt
|
|
+++ b/support-files/CMakeLists.txt
|
|
@@ -62,7 +62,7 @@ IF(UNIX AND NOT WITHOUT_SERVER)
|
|
INSTALL(FILES magic DESTINATION ${inst_location} COMPONENT SupportFiles)
|
|
INSTALL(DIRECTORY policy DESTINATION ${inst_location} COMPONENT SupportFiles)
|
|
FIND_PROGRAM(CHECKMODULE checkmodule)
|
|
- FIND_PROGRAM(SEMODULE_PACKAGE semodule_package)
|
|
+# FIND_PROGRAM(SEMODULE_PACKAGE semodule_package)
|
|
MARK_AS_ADVANCED(CHECKMODULE SEMODULE_PACKAGE)
|
|
|
|
# Build pp files in policy/selinux
|