https://www.postgresql.org/docs/release/15.0/ https://www.postgresql.org/docs/release/15.1/ A dump/restore using pg_dumpall or use of pg_upgrade or logical replication is required for those wishing to migrate data from any previous release. Do not backport to release branch which should remain on version 14. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
10 lines
295 B
Diff
10 lines
295 B
Diff
--- a/src/port/Makefile
|
|
+++ b/src/port/Makefile
|
|
@@ -83,6 +83,7 @@ uninstall:
|
|
libpgport.a: $(OBJS)
|
|
rm -f $@
|
|
$(AR) $(AROPT) $@ $^
|
|
+ $(RANLIB) libpgport.a
|
|
|
|
# getaddrinfo.o and getaddrinfo_shlib.o need PTHREAD_CFLAGS (but getaddrinfo_srv.o does not)
|
|
getaddrinfo.o: CFLAGS+=$(PTHREAD_CFLAGS)
|