packages/net/xtables-addons/patches/001-fix-kernel-version-detection.patch
Rosen Penev e5af506795 xtables-addons: update to 3.19
Fixes compilation with kernel 5.15.

Fixed changed binary name.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2022-04-05 07:34:36 -07:00

11 lines
435 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -42,7 +42,7 @@ regular_CFLAGS="-Wall -Waggregate-return
AS_IF([test -n "$kbuilddir"], [
AC_MSG_CHECKING([kernel version that we will build against])
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
save_IFS="$IFS"
IFS='.'
set x $krel