packages/net/unbound/patches/010-configure-uname.patch
Josef Schlehofer 97e69ec89c
unbound: update to version 1.17.1
- Refreshed one patch
- Removed deprecated AUTORELEASE

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
2023-02-10 15:25:35 +01:00

14 lines
438 B
Diff

OpenWrt (modification):
Fix cross compile errors by inserting an environment variable for the
target. Use "uname" on host only if "UNAME" variable is empty.
--- a/configure.ac
+++ b/configure.ac
@@ -819,7 +819,7 @@ if test x_$ub_test_python != x_no; then
fi
fi
-if test "`uname`" = "NetBSD"; then
+if test "${UNAME:-`uname`}" = "NetBSD"; then
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
AC_SUBST(NETBSD_LINTFLAGS)
fi