packages/net/lighttpd/patches/020-meson-mod_webdav_min.patch
Glenn Strauss ed6fe528c1 lighttpd: add lighttpd-mod-webdav_min package
add lighttpd-mod-webdav_min package alternative to lighttpd-mod-webdav

lighttpd-mod-webdav_min is more minimal than full lighttpd-mod-webdav.
lighttpd-mod-webdav_min does not support PROPPATCH, LOCK, UNLOCK, and
by not supporting those methods, removes dependencies on libxml2,
libsqlite3, and libuuid.

Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
2023-02-20 04:55:39 -05:00

28 lines
700 B
Diff

From fe6895e5eb2c17ddad6e95faaac7d56d4dd73256 Mon Sep 17 00:00:00 2001
From: Glenn Strauss <gstrauss@gluelogic.com>
Date: Fri, 20 Jan 2023 18:48:14 -0500
Subject: [PATCH] [meson] mod_webdav_min w/o deps: xml2 sqlite3 uuid
---
src/meson.build | 8 ++++++++
1 file changed, 8 insertions(+)
--- a/src/meson.build
+++ b/src/meson.build
@@ -865,6 +865,16 @@ if libsasl.found()
]
endif
+modules += [
+ [ 'mod_webdav_min', [ 'mod_webdav.c' ],
+ [ libelftc,
+ declare_dependency(compile_args: [
+ '-DMOD_WEBDAV_BUILD_MINIMAL',
+ '-Dmod_webdav_plugin_init=mod_webdav_min_plugin_init' ] )
+ ]
+ ]
+]
+
foreach mod: modules
mod_name = mod.get(0)
mod_sources = mod.get(1)