packages/net/isc-dhcp/patches/520-bind-no-catgets.patch
Paul Fertser 1e8584dc58 treewide: quote CC and CXX
When CC is set to e.g. "ccache mips-openwrt-linux-musl-gcc" it needs
to be quoted to avoid word splitting on substitution.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
2023-01-20 17:44:14 -08:00

10 lines
507 B
Diff

--- a/bind/Makefile.in
+++ b/bind/Makefile.in
@@ -57,6 +57,7 @@ bind1:
rm -rf ${cleandirs} ${cleanfiles} ; \
(cd ${bindsrcdir} && \
export CC="${CROSS_CC}" AR=${TARGET_AR} RANLIB=${TARGET_RANLIB} && \
+ ac_cv_func_catgets=no \
./configure ${bindconfig} --disable-atomic \
--disable-kqueue --disable-epoll --disable-kqueue \
--disable-epoll --disable-devpoll --without-openssl \