When CC is set to e.g. "ccache mips-openwrt-linux-musl-gcc" it needs to be quoted to avoid word splitting on substitution. Signed-off-by: Paul Fertser <fercerpav@gmail.com>
16 lines
779 B
Diff
16 lines
779 B
Diff
--- a/bind/Makefile.in
|
|
+++ b/bind/Makefile.in
|
|
@@ -56,7 +56,12 @@ bind1:
|
|
echo Configuring BIND libraries for DHCP. ; \
|
|
rm -rf ${cleandirs} ${cleanfiles} ; \
|
|
(cd ${bindsrcdir} && \
|
|
- ./configure ${bindconfig} > ${binddir}/configure.log); \
|
|
+ export CC="${CROSS_CC}" AR=${TARGET_AR} RANLIB=${TARGET_RANLIB} && \
|
|
+ ./configure ${bindconfig} --disable-atomic \
|
|
+ --disable-kqueue --disable-epoll --disable-kqueue \
|
|
+ --disable-epoll --disable-devpoll --without-openssl \
|
|
+ --without-libxml2 --disable-threads --without-gssapi \
|
|
+ --without-randomdev > ${binddir}/configure.log); \
|
|
fi
|
|
|
|
atf: bind1
|