GITWEB_* variable values don't work as they should since 2.38, so let's remove them and add a workaround. This issue was reported in https://lore.kernel.org/git/80eb3972-4960-5727-ce86-acc3a4425fd4@nic.cz/T/#u * refresh patches Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
32 lines
999 B
Diff
32 lines
999 B
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -955,7 +955,8 @@ AC_RUN_IFELSE(
|
|
FILE *f = fopen(".", "r");
|
|
return f != NULL;]])],
|
|
[ac_cv_fread_reads_directories=no],
|
|
- [ac_cv_fread_reads_directories=yes])
|
|
+ [ac_cv_fread_reads_directories=yes],
|
|
+ [ac_cv_fread_reads_directories=no])
|
|
])
|
|
if test $ac_cv_fread_reads_directories = yes; then
|
|
FREAD_READS_DIRECTORIES=UnfortunatelyYes
|
|
@@ -989,7 +990,8 @@ AC_RUN_IFELSE(
|
|
if (snprintf(buf, 3, "%s", "12345") != 5
|
|
|| strcmp(buf, "12")) return 1]])],
|
|
[ac_cv_snprintf_returns_bogus=no],
|
|
- [ac_cv_snprintf_returns_bogus=yes])
|
|
+ [ac_cv_snprintf_returns_bogus=yes],
|
|
+ [ac_cv_snprintf_returns_bogus=no])
|
|
])
|
|
if test $ac_cv_snprintf_returns_bogus = yes; then
|
|
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
|
|
@@ -1012,7 +1014,8 @@ yippeeyeswehaveit
|
|
#endif
|
|
]),
|
|
[ac_cv_sane_mode_bits=yes],
|
|
- [ac_cv_sane_mode_bits=no])
|
|
+ [ac_cv_sane_mode_bits=no],
|
|
+ [ac_cv_sane_mode_bits=yes])
|
|
])
|
|
if test $ac_cv_sane_mode_bits = yes; then
|
|
NEEDS_MODE_TRANSLATION=
|