packages/net/chrony/Makefile
Paul Fertser 0c10c224be treewide: remove AUTORELEASE
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used.

The following temporary change was made to the core:

diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
 abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))

 COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))

 all:
 FORCE: ;

And this command used to fix affected packages:

for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
                              sed 's^.*/\([^/]*\)/Makefile^\1^';);
do
  make package/$i/download
done

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
2023-04-21 22:46:58 +02:00

101 lines
2.7 KiB
Makefile

#
# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=chrony
PKG_VERSION:=4.3
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.tuxfamily.org/chrony/
PKG_HASH:=9d0da889a865f089a5a21610ffb6713e3c9438ce303a63b49c2fb6eaff5b8804
PKG_MAINTAINER:=Miroslav Lichvar <mlichvar0@gmail.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:tuxfamily:chrony
PKG_BUILD_DEPENDS:=pps-tools
PKG_BUILD_FLAGS:=lto
include $(INCLUDE_DIR)/package.mk
define Package/chrony/Default
SUBMENU:=Time Synchronization
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libcap +libpthread
USERID:=chrony=323:chrony=323
TITLE:=A versatile NTP client and server
URL:=http://chrony.tuxfamily.org/
PROVIDES:=nts
endef
define Package/chrony
$(call Package/chrony/Default)
TITLE+= (without NTS)
VARIANT:=normal
CONFLICTS:=chrony-nts
endef
define Package/chrony-nts
$(call Package/chrony/Default)
TITLE+= (with NTS)
DEPENDS+= +PACKAGE_chrony-nts:libgnutls +PACKAGE_chrony-nts:ca-bundle
VARIANT:=with-nts
endef
define Package/chrony/description
An NTP client and server designed to perform well in a wide range
of conditions. It can synchronize the system clock with NTP servers,
reference clocks, and manual input using wristwatch and keyboard.
endef
Package/chrony-nts/description = $(Package/chrony/description)
define Package/chrony/conffiles
/etc/chrony/chrony.conf
/etc/config/chrony
endef
Package/chrony-nts/conffiles = $(Package/chrony/conffiles)
CONFIGURE_ARGS+= \
--host-machine=$(shell echo $(GNU_TARGET_NAME) | sed -e 's/-.*//') \
--host-release="" \
--host-system=Linux \
--sysconfdir=/etc/chrony \
--prefix=/usr \
--chronyrundir=/var/run/chrony \
$(if $(findstring normal,$(BUILD_VARIANT)),--disable-nts,--enable,nts) \
--disable-readline \
--disable-rtc \
--disable-sechash \
--with-user=chrony
CONFIGURE_VARS+=CPPFLAGS=-DNDEBUG
define Package/chrony/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/chronyd $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/chronyc $(1)/usr/bin
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DIR) $(1)/etc/chrony
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_BIN) ./files/chrony.hotplug $(1)/etc/hotplug.d/iface/20-chrony
$(INSTALL_BIN) ./files/chronyd.init $(1)/etc/init.d/chronyd
$(INSTALL_CONF) ./files/chrony.config $(1)/etc/config/chrony
$(INSTALL_CONF) ./files/chrony.conf $(1)/etc/chrony/chrony.conf
endef
Package/chrony-nts/install= $(Package/chrony/install)
$(eval $(call BuildPackage,chrony))
$(eval $(call BuildPackage,chrony-nts))