The previous commit
ba4338d
mmc-utils: don't set -D_FORTIFY_SOURCE in Makefile
applied the global value of FORITFY_SOURCE also to mmc-utils.
As the package was meant to be built with FORTIFY_SOURCE upstream,
restore that behaviour and make it play nice with the global setting
by undefining the macro before defining it.
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
11 lines
466 B
Diff
11 lines
466 B
Diff
Index: mmc-utils-f4eb241519f8d500ce6068a70d2389be39ac5189/Makefile
|
|
===================================================================
|
|
--- mmc-utils-f4eb241519f8d500ce6068a70d2389be39ac5189.orig/Makefile
|
|
+++ mmc-utils-f4eb241519f8d500ce6068a70d2389be39ac5189/Makefile
|
|
@@ -1,5 +1,5 @@
|
|
CC ?= gcc
|
|
-AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
|
|
+AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
|
|
CFLAGS ?= -g -O2
|
|
objects = \
|
|
mmc.o \
|